We highly recommend version 4.4 or higher. This is important for safety and compatibility reasons as well.