Temporary discount: only $ 79,-
Regular price: $ 119.- Only in June 2021

Yes. We highly recommend you to use WooCommerce 2.0 or higher(!). The plugin is tested with lower versions of WooCommerce 2.0 and it worked fine. But we highly recommend you to use it with WooCommerce 2.0 or higher.